Problemlösung: Office Dokumente lassen sich nicht mehr direkt aus SharePoint öffnen

Heute möchte ich einen ersten Problemlösungsvorschlag zu einem doch häufiger vorkommende Problem beschreiben. Schließlich sind es meistens genau diese kleinen bis großen Probleme, die viel Zeit kosten und deren Lösung man im Internet sucht. In Zukunft findet man die Einträge direkt unter der Kategorie und mit der Überschrift Problemlösung.

Worum geht es heute?

Wenn man ein Office Dokument direkt aus SharePoint im Client öffnen will kommt eine Meldung, dass die Seite nicht gefunden werden kann. Das Dokument ist allerdings in Ordnung. Wenn man die Datei herunterlädt, oder die WebApps benutzt kann man damit arbeiten.

Ein Blick in die Adressleiste verrät nun, dass der Browser z.B. folgende Link aufrufen will „ms-word:ofv|u|http://…“. Damit hat man schon den ersten Hinweis, dass es sich um ein Client Problem rund um Office handelt.

In welcher Systemumgebung tritt das Problem auf? Office 2010. Nach kurze Recherche bin ich auf die Lösung gestossen. Durch die Installation einer einzelnen neuen Komponente von Office 2013 kann es zu diesem Problem bei den Dateizuordnungen kommen. Gerade mit Office 365 ist das schnell passiert. SharePoint designer 2013, Lync 2013 lassen sich schließlich direkt aus dem Account herunterladen.

Anscheinend wird durch die Installation die OpenDocumentClass (OWSSUPP.DLL) im Internet Explorer geändert und Office 2010 kommt nun damit gar nicht mehr zurecht.

Als erstes sollte man also den „Übeltäter“ wieder beseitigen, sprich die Office 2013 Anwendung deinstallieren. Eventuell ist danach noch eine Reparatur von Office 2010 notwendig.

Wenn man nun wirklich eine einzelne Office 2013 Anwendung benötigen sollte, ist man leider noch im Nachteil. Das Problem ist zwar schon seit Monaten bekannt, aber erst vor kurzem immer noch aufgetreten. Ein kurzfristiger Work-Around ist auch das Deaktivieren des Add-ons „SharePoint OpenDocuments Class“ (siehe auch http://www.ehow.com/info_12198311_sharepoint-opendocuments-class-addon.html)

Bisher ist mir dieses Problem nur bei Windows 7 Systemen untergekommen.

Die Beste Lösung: Office 2013 vollständig installieren 🙂

Advertisements

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s